Back to overview
Issue with upstream provider
Jun 12 at 06:45pm UTC
Affected services
ReportGarden
Resolved
Jun 12 at 06:45pm UTC
We are currently experiencing issues with Google-related data sources due to a broader outage affecting multiple Google services. As a result, some of our dependent services are also impacted, and data loading functionality may be temporarily unavailable.
We are actively monitoring the situation and will provide updates as more information becomes available. We appreciate your patience and understanding.
Affected services